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How To Create Your Maps
To Top
Thanks go to Apache for the screen_dump tip.

This is meant only for if you don't have a scanner(which I don't), aren't all that talented at drawing on a 
computer(I'm not), or too lazy to actually draw a map(shame on you).

1. First, you'll need a few things, one is MS Paint(which everyone should have), Gimp(freeware, 
Yay!) download it and install. You will also need some blank maps, use either mine or tomi's. 

2. Open your mission. 
3. Create an area brush around the area you want to put on one of your maps. 
4. Select the area brush and select Me Only. 
5. Select Filter and filter out everything except terrain. 
6. Set the Top view to Solo and zoom out(or in) until you get the largest size that will fit on your 

screen. 
7. Take a screen shot by typing screen_dump into the command box. The screen shot will be saved 

in the directory where Dromed is installed named dump000.pcx etc. Open the screen shot in 
Gimp, right click on the image and go to File>Save As... and save it as a .bmp file. 

8. Open the .bmp in Paint, crop it to an appropriate size(only your map area is shown in the image, 
plus a small amount of space on the outside). You should have something as follows:

http://thief1.math.uh.edu/thief/media/maps/blankmaps_v2.zip
http://www16.brinkster.com/salvage/dromed/download/maptut/maps_rp.zip
http://w0w.wingimp.org/download.php


9. Save the image and set the Save As Type to Monochrome Bitmap. The results should be similar to 
this:

10.Next Click on Image>Invert Colors, You should now have black lines on a white background. As 
follows:



11.Next, clean up your image, use Paint's handy fill tool and erasor to get the image looking right. 
You will probably have to fix a few things.

12.After you're done cleaning up the image, save it and open the image in Gimp. 
13.Right click on the image and go to Image>Scale Image..., set the height to 300 px (pixels) and hit 

OK. If the width is larger than 530 px then set the width to 530 px instead. The actual size of the 
maps are 552 px width and 360 px height. If the resulting size is too large then you will have to set 
the other specification.



14.Fix your image of any problems that happened when you shrunk(Tip: to draw a straight line using 
the pencil tool move the mouse to where you want a line to begin and hold shift down, then move 
to where you want the line to finish and left click, release shift), add any arrows or markings you 
wish to add to the image(DO NOT PUT ANY TEXT ON THE IMAGE, it will be added later).

Making The Map Dirty 
15.Right Click on the image and go to Select>By Color..., set the Fuzzyness Threshold to zero(0) and 

click on a black line in your image, right click on your image and go to Edit>Copy. 
16.Choose which map background you are going to use and open it in Gimp. Right click on the map 

image and go to Edit>Paste, position it where you want it and right click and go to Layers>Anchor 
Layer.

17.Paint over any black on the edges with white. (Tip: use the selection tool(dotted box) to select the 



area your map is in, right click and go to Select>Invert, and use the fill tool(paint can) to fill the 
outside with white).

18.Save the image as a bitmap(bmp)(to save in Gimp right click the image go to File>Save As). 
Close the image in Gimp, but don't close Gimp. 

19.Open the image you just saved in Paint, go to File>Save As... and change the Save As Type: to 
24-Bit Bitmap and save over the file. 

20.Open the image in Gimp. 
21.Right click on the image and go to Layers>Layers, Channels, and Paths... 
22.In the new window right click on Background and go to Duplicate Layer, right click on the new 

layer and go to Edit Layer Attributes... and rename it to Waves, set the Opacity slider to 40. 
Repeat two(2) more times, naming the new layers Horiz Ripple and Vert Ripple, remember to set 
the Opacity slider to 40. 

23.Select the Waves layer, right click on the image and go to Filters>Distorts>Waves. Set Amplitude 
to 1.30 amd Wavelength to 50, leave everything else as it is and click on OK. 

24.Select the Horiz Ripple layer, right click on the image and go to Filters>Distorts>Ripple.... Click 
on Horizontal under Orientation, set Period to 200, and Amplitude to 1. Click OK. 

25.Select the Vert Ripple layer, right click on the image and go to Filters>Distorts>Ripple.... Click 
on Vertical under Orientation, set Period to 200, and Amplitude to 1. Click OK. 

26.Right click on the image and go to Layers>Flatten Image.

27.Right Click on the image and go to Select>By Color..., set the Fuzzyness Threshold to 110 and 
click on a black line in your image, right click on your image and go to Edit>Copy. 

28.Choose which map background you are going to use and open it in Gimp. Right click on the map 
image and go to Edit>Paste, position it where you want it and right click and go to Layers>Anchor 
Layer. 

29.Paint over any black on the edges with white. (Tip: use the selection tool(dotted box) to select the 
area your map is in, right click and go to Select>Invert, and use the fill tool(paint can) to fill the 
outside with white).



30.Save the image as a bitmap(bmp)(to save in Gimp right click the image go to File>Save As). 
Close the image in Gimp, but don't close Gimp. 

31.Open the image you just saved in Paint, go to File>Save As... and change the Save As Type: to 
24-Bit Bitmap and save over the file. 

32.Open the image in Gimp. 
33.Add any text to your image now. If you are doing multilingual maps(please do) you are going to 

have to do different versions of your map starting here.

34.Right click on the image and go to Layers>Layers, Channels, and Paths... 
35.In the new window right click on Background and go to Duplicate Layer, right click on the new 

layer and go to Edit Layer Attributes... and rename it to Waves, set the Opacity slider to 40. 
36.Select the Waves layer, right click on the image and go to Filters>Distorts>Waves. Set Amplitude 

to 1.35 amd Wavelength to 50, leave everything else as it is and click on OK. 
37.Right click on the image and go to Layers>Flatten Image.

38.Right Click on the image and go to Select>By Color..., set the Fuzzyness Threshold to 110 and 
click on a black line in your image, right click on your image and go to Edit>Copy. 

39.Choose which map background you are going to use and open it in Gimp. Right click on the map 
image and go to Edit>Paste, position it where you want it and right click and go to Layers>Anchor 
Layer. 

40.Right click on your newly created map, go to File>Save As... and name it something else(like 
page000.pcx in another directory), this is your completed map image, ready to be put into Thief 1/
Gold or Thief 2.



The Basic Map
To Top

1. Draw your map   and save it in .pcx format(must begin with page followed by a 3 digit number (eg. 
page000.pcx). For multiple pages save them from 0 to whatever number of pages you have (like 
page000.pcx to page007.pcx for 8 pages) 
MAKE SURE THAT THE MAP IS SAVED WITH THE THIEF PALETTE. If you are using one 
of the maps from my map pack you don't have to worry about it. tomi's maps are sort of saved to 
the thief pallette, the transparent color is different in them, but the pink color is the same, see 
below on how to change the transparent color. If you've created your own, then you can do one of 
three things, you can paste your map over top of one of my blank maps and save(select all on your 
map, ctrl-c, select the blank, ctrl-v, save), you can load the palette and save your map with that 
palette. Palette for Photoshop(Image>Mode>Color Table>Load), Paint Shop Pro(Colors>Load 
Pallette), and Photopaint, or you can edit the pallette manually.

Gimp Pallette
For the pink outline color, right click in Gimp and go to Dialogs>Indexed Pallette, right click on 
index 254(use the arrows beside index to identify it) and go to edit. In the bottom right beside Hex 
Triplet enter #ff00ff and click OK. For the green transparent color, right click in Gimp and go to 
Dialogs>Indexed Pallette, right click on the top left square(index 0) and go to edit. In the bottom 
right beside Hex Triplet enter #64ff05 and click OK.

Photoshop 6 Pallette
In Photoshop 6, for the pink outline color, go to Image>Mode>Color Table, click on the second 
color to the right at the top row. In the box beside # enter the hex number ff00ff and click OK. 
Next, for the green transparent color, go to the the very bottom right color and click on it, in the 
box beside # enter the hex number 64FF05 and click OK.

Paint Shop Pro 7 Palette
In Paint Shop Pro 7, for the pink outline color, go to Colors>Edit Pallette, double click on the 
second color to the left at the bottom row. In the box beside HTML Code: enter the hex number 

http://www16.brinkster.com/salvage/dromed/download/maptut/thief_photopaint.ZIP
http://www16.brinkster.com/salvage/dromed/download/maptut/thiefpal_psp.ZIP
http://www16.brinkster.com/salvage/dromed/download/maptut/thief_adobe.ZIP
http://www16.brinkster.com/salvage/dromed/download/maptut/maps_rp.zip


#ff00ff and click OK. Next, for the green transparent color, go to the the very top left color and 
click on it, in the box beside HTML Code: enter the hex number #64FF05 and click OK.

For those not using Gimp, Photoshop 6, or Paint Shop Pro 7 the following table will be helpful. 
Box Color  Transparent Color

H = 300 L = 60  H = 97 L = 89

S = 100 a = 94  S = 98 a = -68

B = 100 b = -60  B = 100 b = 82

R = 255 C = 42  R = 100 C = 50

G = 0 M = 64  G = 255 M = 0

B = 255 Y = 0  B = 5 Y = 88

#ff00ff K = 1  #64ff05 K = 0

2. Now, create a directory called intrface(notice there is no e between the t and r) and inside it create 
another directory named after your mission(miss19, miss27, etc.). 

3. Put your maps into your mission directory(miss19, etc.). If you have text on your map you may 
want to make it multilingual so put the English version in the English directory inside your 
mission directory(French in french, German in german, English in english). Note: if you make 
your maps multilingual then you must not have any maps in the mission directory or they will 
override the maps in the language directories. 

4. In Dromed, go to Editors (on the menu bar), click on mission parameters, and click on Dark 
Mission Description and then on OK.

 
In the first line put the number of your mission (19, 27, etc.), in the second put the name of your 
mission (miss19, miss27, etc.) 

5. Next, in Dromed in the command box in the corner type in
quest_create_mis map_min_page, 0
quest_create_mis map_max_page, 0 for one map if you started with map 0 (for more you would 
replace the number in max map for the highest number of your maps).



You Should Now Have A Basic Map

Automaps
To Top

1. Follow the guidelines for The Basic Map. 
2. Draw boxes(they must be rectangular and the lines can be no larger than 1 pixel thick) around the 

rooms in color 254, the pink color in pg.pcx in my blank maps pack, use the color picker tool in 
Gimp to get the color from pg.pcx. Tip: to draw a straight line using the pencil tool move the 
mouse to where you want a line to begin and left click, then hold Shift and Ctrl down, then move 
to where you want the line to finish and left click, release shift and Ctrl. You will need to have 
more than one of these boxed maps to have a complete and fully functional automap. Save these 
maps as p000ra.pcx, p000rb.pcx, p000rc.pcx etc. for page000.pcx, and save them as p001ra.pcx, 
p001rb.pcx etc. for page001.pcx, and so on for all your maps.

  

 

3. For each of the boxed maps fill in the areas inside the pink boxes that you don't want to show up 
on the the map screen(these parts will be transparent) with the green color from pg.pcx. Save the 
files. Close Gimp, it's no longer needed.

  

http://www16.brinkster.com/salvage/dromed/download/maptut/maps_rp.zip


 

4. Extract the map tools(cutout.exe and makerect.exe), copy the images you just made into the 
directory where you extraced the map tools. 

5. Open Notepad, enter:
cutout p003ra.pcx p003rb.pcx p003rc.pcx p003rd.pcx
makerect p003ra.pcx p003rb.pcx p003rc.pcx p003rd.pcx
Only do one map page at a time, or there will be big problems. 

6. Go to File>Save As..., set Save as type: to All Files (*.*), enter "map.bat"(with the quotes) and 
save it to where you extracted the map tools. 

7. Run map.bat by double clicking on it, a dos box should pop up, wait until it says finished on the 
bar ar the top. You should have a number of new pcx files where you extracted the map tools, 
these are your room files. If you're doing multi-language maps make sure the room images are 
named the same for each corresponding map area.

 

8. Copy the map, rooms, .bin and p000ra,b,etc. files to the intrface\miss# directory (and language 
directories if needed). 

9. In Dromed, go to the Object Hierarchy found under editors. Change the Show Tree: to Rooms. 
Click on default room and click on Add and name a new room type. Make a new room type for 
each different room file (p000r000, etc.). 

10.Make your rooms using the newly created room brushes, one type for each room picture. You 
would use the same room type for a squiggly hallway that has only one room picture for it. 

11.Now, for each room you must click on edit (the one at the bottom of the screen), add, then room, 
then automap. In the dialogue box enter the map page and enter the room number (0, then 1 for 
p000r001.pcx to be displayed over page000.pcx)

You Should Now Have An Automap

http://www16.brinkster.com/salvage/dromed/download/maptut/maptools.zip


Auto Updating Map(Dromed 2/Thief 2 Only)
To Top

1. Pretty simple, do complete Automaps of your level, then replace the base maps (page000.pcx, 
etc.) with the original blank maps that you used to create your map in the first place.

Now The Map Will Update As The Player Enters The Rooms.

How To Make A Map Out Rooms Objective(Dromed 2/Thief2 Only)
To Top
Thanks go to telliamed for pointing me in the right direction.

1. Complete Auto Updating Maps. 
2. For the text of the objective, open Notepad, and enter

fiction_x: "Enter Loading Objectives Screen Text Here"
text_x: "Enter In Game Objectives Screen Text Here"
Where x is the number of your objective, there is one space after the colon (:) and the text is 
enclosed in quotation marks.

Save it as "goals.str" (including the quotes) and put it in the intrface\miss#\languages directory 
where your maps are (such as intrface\miss17\english\goals.str). 

3. Create an objective by entering into the command box: quest_create_mis goal_state_x, 0 for 
incomplete and quest_create_mis goal_visible_x, 1 where x is the number of your objective and it 
is a visible objective (I don't know why you would want an invisible map out rooms objective). 

4. Enter quest_create_mis map_locs_visited, 0 into the command box. 
5. Create a QuestVarTrap (-1823). Click on properties, click add>Trap>Quest Var. In the dialogue 

box enter =1:goal_state_x where x is the number of your objective, this marks the objective as 
complete when it becomes complete.

6. Create a QuestVarTrigger (-4370). Click on properties, click add>Trap>Quest Var. In the dialogue 
box enter >n:map_locs_visited where n is the number of rooms you want to be mapped out before 
the objective completes. Room types are counted, not room objects.

7. ControlDevice link the QuestVarTrigger to the QuestVarTrap and it's done.
Note: when testing this you must close and re-open Dromed, as Dromed keeps the 
map_locs_visited variable in memory after leaving game mode. 



Add New Map(s) In Game
To Top

1. Open Notepad. 
2. Enter Page_0: "New Map Found" 
3. Save As "newmap.str" in the books>language directory(which you have to create in the directory 

where Dromed is). 
4. In Dromed create a marker(-36). Rename it to something like addmap1. 
5. Add>S>Scripts, enter StdButton and StdBook 
6. Add>Book>Text, enter newmap 
7. Add>Engine Features>Frobinfo, enter Script, Delete for world options, leave the others empty. 
8. Add>Renderer>Render Type, change it to normal. 
9. Add>Shape>Model Name, enter one of the names from the following: 

Scroll Models
Dromed Name Dromed 1 Model Dromed 2 Model

CrumpledPaper N/A paperb1

HammerScroll parch3 hamscrol

LC_Scroll lcscroll lcscroll

LC_Scroll2 lcscrosp lcscrosp

Papyrus scroll scroll

Schematic N/A buscroll

Unrolled Scroll scrollop scrollop

10.Create a QuestVarTrap(-1823) 
11.Add>Trap>Quest Var, enter =x:map_max_page where x is the number of the highest map you 

want to be available on the map screen. =x:map_min_page can also be used where x is the number 
of the lowest map you want to be available on the map screen. 

12.Control Device link the renamed marker to the QuestVarTrap. 
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